Scott Rose
Impact in
-
- Network Security and Intrusion Detection
- Cybersecurity and Information Systems
- Advanced Authentication Protocols Security
- Network Traffic and Congestion Control
- Caching and Content Delivery
- Artificial Intelligence top 10%
- Security and Verification in Computing
- Internet Traffic Analysis and Secure E-voting
- Cryptography and Data Security
Papers in
-
- Network Security and Intrusion Detection 12
- Cybersecurity and Information Systems 11
- Distributed systems and fault tolerance 3
- Advanced Authentication Protocols Security 2
-
- Security and Verification in Computing 10
- Co-authors
- Roy Arends (3 shared papers)Rob Austein (3 shared papers)Daniel F. Massey (3 shared papers)Ramaswamy Chandramouli (5 shared papers)Anastase Nakassis (2 shared papers)Kevin L. Mills (3 shared papers)Zheng Wang (4 shared papers)Kevin D. Bowers (2 shared papers)
- Journals
- IEEE Security & Privacy (3 papers)IEEE Network (1 paper)Digital Communications and Networks (1 paper)Sustainable Computing Informatics and Systems (1 paper)Lecture notes of the Institute for Computer Sciences, Social Informatics and Telecommunications Engineering (1 paper)
- Partner nations
- United StatesAustraliaChina
In The Last Decade
Scott Rose
20 papers receiving 250 citations
Peers
Comparison fields: 5 of 14
- Computer Networks and Communications 232
- Artificial Intelligence 123
- Information Systems 50
- Hardware and Architecture 4
- Sociology and Political Science 24
Countries citing papers authored by Scott Rose
This map shows the geographic impact of Scott Rose's research. It shows the number of citations coming from papers published by authors working in each country. You can also color the map by specialization and compare the number of citations received by Scott Rose with the expected number of citations based on a country's size and research output (numbers larger than one mean the country cites Scott Rose more than expected).
Fields of papers citing papers by Scott Rose
This network shows the impact of papers produced by Scott Rose. Nodes represent research fields, and links connect fields that are likely to share authors. Colored nodes show fields that tend to cite the papers produced by Scott Rose. The network helps show where Scott Rose may publish in the future.
Co-authors
The 13 scholars most cited alongside Scott Rose, linked wherever they have co-authored with each other. Click a name or a connecting line to browse the papers they share.
All Works
Showing the 20 most-cited of 21 papers — load more, or switch the sort, to bring in the rest.
| # | Work | ||
|---|---|---|---|
| 1 | DNS Security Introduction and Requirements, RFC 4033 | NIST | 2005 | 90 |
| 2 | Resource Records for the DNS Security Extensions, RFC 4034 | NIST | 2005 | 61 |
| 3 | Protocol Modifications for the DNS Security Extensions RFC 4035 | NIST | 2005 | 55 |
| 4 | 2004 | 13 | |
| 5 | 2006 | 12 | |
| 6 | 2006 | 9 | |
| 7 | 2008 | 8 | |
| 8 | 2017 | 8 | |
| 9 | 2009 | 7 | |
| 10 | 2004 | 6 | |
| 11 | 2004 | 3 | |
| 12 | 2009 | 3 | |
| 13 | [Project Description] Implementing a Zero Trust Architecture (Draft) | 2020 | 3 |
| 14 | Signaling Cryptographic Algorithm Understanding in DNSSEC | 2010 | 2 |
| 15 | DNS Resource Records for ILNP | 2011 | 2 |
| 16 | 2018 | 2 | |
| 17 | Discovering And Accessing Software Bills of Materials | 1998 | 1 |
| 18 | DNS Security Document Roadmap | 2000 | 1 |
| 19 | 2009 | 1 | |
| 20 | 2018 | 1 |
About Scott Rose
Scott Rose is a scholar working on Computer Networks and Communications, Artificial Intelligence, Information Systems, Control and Systems Engineering and Hardware and Architecture, having authored 21 papers that have together received 288 indexed citations. Recurring topics across this work include Network Security and Intrusion Detection (12 papers), Cybersecurity and Information Systems (11 papers), Security and Verification in Computing (10 papers), Distributed systems and fault tolerance (3 papers), Access Control and Trust (2 papers), Smart Grid Security and Resilience (2 papers), Information and Cyber Security (2 papers) and Advanced Authentication Protocols Security (2 papers). The work is most often cited by research in Computer Networks and Communications (232 citations), Artificial Intelligence (123 citations), Information Systems (50 citations), Hardware and Architecture (4 citations) and Sociology and Political Science (24 citations). Scott Rose has collaborated with scholars based in United States, Australia and China. Frequent co-authors include Roy Arends, Rob Austein, Daniel F. Massey, Ramaswamy Chandramouli, Anastase Nakassis, Kevin L. Mills, Zheng Wang, Kevin D. Bowers, Jun Huang and Eliot Lear. Their work appears in journals such as IEEE Security & Privacy, IEEE Network, Digital Communications and Networks, Sustainable Computing Informatics and Systems and Lecture notes of the Institute for Computer Sciences, Social Informatics and Telecommunications Engineering.
Rankless uses publication and citation data sourced from OpenAlex, an open and comprehensive bibliographic database. While OpenAlex provides broad and valuable coverage of the global research landscape, it—like all bibliographic datasets—has inherent limitations. These include incomplete records, variations in author disambiguation, differences in journal indexing, and delays in data updates. As a result, some metrics and network relationships displayed in Rankless may not fully capture the entirety of a scholar's output or impact.