Tim Chown
Impact in
-
- Network Traffic and Congestion Control
- Network Security and Intrusion Detection
- Software-Defined Networks and 5G
- Opportunistic and Delay-Tolerant Networks
-
- IPv6, Mobility, Handover, Networks, Security
Papers in
-
- Network Traffic and Congestion Control 7
- Distributed and Parallel Computing Systems 4
- Network Security and Intrusion Detection 3
- Opportunistic and Delay-Tolerant Networks 1
-
- IPv6, Mobility, Handover, Networks, Security 19
- Co-authors
- Pekka Savola (1 shared paper)Sophie Stalla-Bourdillon (3 shared papers)Evangelia Papadaki (2 shared papers)Dave Thaler (1 shared paper)Richard Draves (1 shared paper)Danius T. Michaelides (3 shared papers)Michelle Bachler (3 shared papers)David De Roure (3 shared papers)
- Journals
- IEEE Internet Computing (1 paper)Lecture notes in computer science (1 paper)Symposium on Applications and the Internet Workshops (SAINT Workshops) (3 papers)International Conference on Acoustics, Speech, and Signal Processing (1 paper)EPJ Web of Conferences (4 papers)
- Partner nations
- United KingdomUnited StatesSwitzerland
In The Last Decade
Tim Chown
28 papers receiving 124 citations
Peers
Comparison fields: 5 of 31
- Computer Networks and Communications 53
- Electrical and Electronic Engineering 56
- Information Systems 19
- Human-Computer Interaction 4
- Information Systems and Management 4
Countries citing papers authored by Tim Chown
This map shows the geographic impact of Tim Chown's research. It shows the number of citations coming from papers published by authors working in each country. You can also color the map by specialization and compare the number of citations received by Tim Chown with the expected number of citations based on a country's size and research output (numbers larger than one mean the country cites Tim Chown more than expected).
Fields of papers citing papers by Tim Chown
This network shows the impact of papers produced by Tim Chown. Nodes represent research fields, and links connect fields that are likely to share authors. Colored nodes show fields that tend to cite the papers produced by Tim Chown. The network helps show where Tim Chown may publish in the future.
Co-authors
The 25 scholars most cited alongside Tim Chown, linked wherever they have co-authored with each other. Click a name or a connecting line to browse the papers they share.
All Works
Showing the 20 most-cited of 35 papers — load more, or switch the sort, to bring in the rest.
| # | Work | ||
|---|---|---|---|
| 1 | Memetic: An Infrastructure for Meeting Memory | 2006 | 24 |
| 2 | RFC 6724: default address selection for Internet Protocol Version 6 (IPv6) | 2012 | 15 |
| 3 | 2005 | 14 | |
| 4 | 2003 | 13 | |
| 5 | 2014 | 9 | |
| 6 | 2003 | 8 | |
| 7 | IPv6 Implications for TCP/UDP Port Scanning | 2005 | 5 |
| 8 | Memetic: From Meeting Memory to Virtual Ethnography & Distributed Video Analysis | 2006 | 5 |
| 9 | Home networking architecture for IPv6 | 2011 | 5 |
| 10 | 2015 | 5 | |
| 11 | RFC 5157: IPv6 Implications for Network Scanning | 2008 | 4 |
| 12 | 2014 | 4 | |
| 13 | 2003 | 3 | |
| 14 | 2006 | 3 | |
| 15 | RFC 5375: IPv6 Unicast address assignment considerations | 2008 | 3 |
| 16 | The Use of Firewalls in an Academic Environment | 2000 | 2 |
| 17 | 2006 | 2 | |
| 18 | 2006 | 2 | |
| 19 | Things to think about when Renumbering an IPv6 network | 2006 | 2 |
| 20 | IPv6 Campus Transition Scenario Description and Analysis | 2006 | 2 |
About Tim Chown
Tim Chown is a scholar working on Computer Networks and Communications, Electrical and Electronic Engineering, Computer Vision and Pattern Recognition, Law and Computer Graphics and Computer-Aided Design, having authored 35 papers that have together received 141 indexed citations. Recurring topics across this work include IPv6, Mobility, Handover, Networks, Security (19 papers), Network Traffic and Congestion Control (7 papers), Distributed and Parallel Computing Systems (4 papers), Digitalization, Law, and Regulation (3 papers), Network Security and Intrusion Detection (3 papers), Image Retrieval and Classification Techniques (2 papers), Data Visualization and Analytics (2 papers) and Opportunistic and Delay-Tolerant Networks (1 paper). The work is most often cited by research in Computer Networks and Communications (53 citations), Electrical and Electronic Engineering (56 citations), Information Systems (19 citations), Human-Computer Interaction (4 citations) and Information Systems and Management (4 citations). Tim Chown has collaborated with scholars based in United Kingdom, United States and Switzerland. Frequent co-authors include Pekka Savola, Sophie Stalla-Bourdillon, Evangelia Papadaki, Dave Thaler, Richard Draves, Danius T. Michaelides, Michelle Bachler, David De Roure, Rob Procter and Clara Mancini. Their work appears in journals such as IEEE Internet Computing, Lecture notes in computer science, Symposium on Applications and the Internet Workshops (SAINT Workshops), International Conference on Acoustics, Speech, and Signal Processing and EPJ Web of Conferences.
Rankless uses publication and citation data sourced from OpenAlex, an open and comprehensive bibliographic database. While OpenAlex provides broad and valuable coverage of the global research landscape, it—like all bibliographic datasets—has inherent limitations. These include incomplete records, variations in author disambiguation, differences in journal indexing, and delays in data updates. As a result, some metrics and network relationships displayed in Rankless may not fully capture the entirety of a scholar's output or impact.